Information for RPM bouncycastle-1.80-4.ocs23.src.rpm
| ID | 325660 | ||||||||||||||||||
|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|---|
| Name | bouncycastle | ||||||||||||||||||
| Version | 1.80 | ||||||||||||||||||
| Release | 4.ocs23 | ||||||||||||||||||
| Epoch | |||||||||||||||||||
| Arch | src | ||||||||||||||||||
| Summary | Bouncy Castle Cryptography APIs for Java | ||||||||||||||||||
| Description | The Bouncy Castle APIs currently consist of the following: - A lightweight cryptography API for Java and C#. - A provider for the Java Cryptography Extension (JCE) and the Java Cryptography Architecture (JCA). - A provider for the Java Secure Socket Extension (JSSE). - A clean room implementation of the JCE 1.2.1. - A library for reading and writing encoded ASN.1 objects. - Lightweight APIs for TLS (RFC 2246, RFC 4346) and DTLS (RFC 6347/ RFC 4347). - Generators for Version 1 and Version 3 X.509 certificates, Version 2 CRLs, and PKCS12 files. - Generators for Version 2 X.509 attribute certificates. - Generators/Processors for S/MIME and CMS (PKCS7/RFC 3852). - Generators/Processors for OCSP (RFC 2560). - Generators/Processors for TSP (RFC 3161 & RFC 5544). - Generators/Processors for CMP and CRMF (RFC 4210 & RFC 4211). - Generators/Processors for OpenPGP (RFC 4880). - Generators/Processors for Extended Access Control (EAC). - Generators/Processors for Data Validation and Certification Server (DVCS) - RFC 3029. - Generators/Processors for DNS-based Authentication of Named Entities (DANE). - Generators/Processors for RFC 7030 Enrollment over Secure Transport (EST). - A signed jar version suitable for JDK 1.4-1.15 and the Sun JCE. | ||||||||||||||||||
| Build Time | 2026-08-06 13:15:37 GMT | ||||||||||||||||||
| Size | 45.60 MB | ||||||||||||||||||
| 2b01816530da2b282b418c8465dfaa91 | |||||||||||||||||||
| License | MIT | ||||||||||||||||||
| Buildroot | dist-ocs23-base-build-374743-47412 | ||||||||||||||||||
| Provides |
|
||||||||||||||||||
| Obsoletes | No Obsoletes | ||||||||||||||||||
| Conflicts | No Conflicts | ||||||||||||||||||
| Requires |
|
||||||||||||||||||
| Recommends | No Recommends | ||||||||||||||||||
| Suggests | No Suggests | ||||||||||||||||||
| Supplements | No Supplements | ||||||||||||||||||
| Enhances | No Enhances | ||||||||||||||||||
| Files |
|
||||||||||||||||||
| Component of | No Buildroots | ||||||||||||||||||

